Planned Outage: 24th February 2021, 7:30am - 8:30am AEDT
Completed
Scheduled for February 23, 2022 at 8:30 PM – 9:30 PM
Affects
Payments
Under maintenance from 8:30 PM to 9:30 PM
Updates
Completed
February 23, 2022 at 9:30 PM
Completed
February 23, 2022 at 9:30 PM
Maintenance has completed successfully
In progress
February 23, 2022 at 8:30 PM
In progress
February 23, 2022 at 8:30 PM
Maintenance is now in progress
Planned
February 23, 2022 at 8:30 PM
Planned
February 23, 2022 at 8:30 PM
Planned Outage: 24th February 2021, 7:30am - 8:30am AEDT
Updates will be applied to Wise-Sync and Wise-Pay at this time and you may not be able to log in. If you have any questions or concerns, please contact support@wise-sync.com.